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Model Answers Book 7 : CODING AND HTML
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|. Answer the following questions:
1. What are the four main functions of a Computer?
Ans. The four main functions of a Computer are:

1. Receiving input

2. Processing information

3. Storing information

4. Producing output

2. What is the use of the DVD-ROM drive?

Ans. DVD-ROM drive allows you to access the data stored on a CD or a
DVD. Data can also be written, modified, or erased with the help
of the drive.

3. Name any three portable computers.

Ans. Laptop PC, Netbook PC and Tablet PC are portable computers.

ll. Match the following:
Ans. 1) e 2 c 3) d 4) f 5 b 6) a

l1I. Fill in the blanks:
Ans. 1. Input 2. RAM 3. Hard disk drive

4. Supercomputers



S Security %

E‘\E I L‘!‘b"'[ ::

|. Answer the following questions:

1. What is computer virus?

Ans. A computer virus is a program that copies itself into other
programs on the computer causing damage to either the system
software, hardware or personal information.

2. Name and describe any two types of Internet threats.

Ans. 1. Spam: Emails from unknown accounts offering you links with
too-good-to-be-true offers and promotions are called spam
and usually contain malware when opened.

2. Spyware: It infects in the computer when you download and install
free software or files from unsafe websites on the internet. Once a
Spyware program is installed, it starts collecting personal information
from your computer without your permission. It steals information
and gives or sells it on the internet.

3. Adware: It is similar to Spyware, but instead of collecting your
personal information it displays pop-up advertisements when you surf
the internet. It tracks your activity and search history on the internet
and based on the information displays advertisements.

4. Worm: The Worm is a common threat to computers and the Internet.
It can duplicate itself and multiply. Worms can copy themselves to
all the computers connected in the network on its own. It stays
active in an infected computer’s memory.

5. Trojan Horse: It is a type of malware program that gets installed along
with genuine software like games or utility applications. It deletes
your files and allows hackers to access your computer remotely.

(Note: Teacher may ask students to write any two from the above
threats.)



2. Internet Security

lI. Fill in the blanks:

Ans. 1. Malware
2. Spyware
3. Adware
4. Trojan Horse
5. Windows Defender



l. Answer the following questions:
1. What is SmartArt? List the steps to add SmartArt.

Ans. SmartArt creates a visual representation of information.

To add SmartArt:
1. On the Insert tab, click on SmartArt in the Illustrations group.

2. Click on the required SmartArt graphic from the Choose a
SmartArt Graphic dialog box that opens.

3. The selected SmartArt would be added to the slide.

4. Enter your text information in the SmartArt and resize it within
the slide.

2. What are Charts? List the steps to add Charts.

Ans. If you have large quantities of data to show, you can use charts to

represent the data in a graphical format.

To add Charts:

1. On the Insert tab, click on Chart in the Illustrations group.
2. The Insert Chart dialog box will open.

3. Choose from the different categories of Charts.

4. Select a chart and it will be added in the slide pane along with
an Excel window to enter the data.

5. To edit the chart styles, click on the Design tab, click on the
drop-down arrow in the Chart Styles group and choose from the
different styles.

ll. Match the following:

Ans.

1) d 2) b 3) ¢ 4) a



|. Answer the following questions:
1. What are the steps to add an audio to your presentation?
Ans. 1. Select the slide to add the sound.

2. On the Insert tab, click on Audio in the Media group.

3. Insert an audio from the two sources i.e. Audio on My PC and
Record Audio.

4. Resize the loudspeaker () like shaped icon that appears in the
slide. We can relocate the icon anywhere within the slide.

5. On the Ribbon, two additional tabs are activated Format and
Playback. The Playback tab allows you to Trim, Fade In and
Fade Out, Volume, Loop, Rewind etc. the audio.

2. What is the advantage of converting your presentation into a video?

Ans. If we convert our presentation into a video, this allows you to play
the presentation on your smartphone, computer or any other
media devices as the video is prepared in MP4 format.

[I. Fill in the blanks:

Ans. 1. Media 2. Online Video 3. Screen recording



|. Answer the following questions:

1. What are Slide Transitions?

Ans. A slide transition in a presentation is how one slide is followed by
the next slide.

2. Write down the steps to apply Slide Transitions in PowerPoint.
Ans. 1. Select the slide you want to apply the slide transition.

2. On the Transitions tab, click on the more drop-down arrow in
the Transition to This Slide group.

3. Choose the desired effect. Menu of Slide Transition Effects from
the drop-down menu of slide transition effects.

4. Click on Preview in the Transitions tab to view the slide
transition.

5. Every slide transition effect can be further customized by
clicking on Effect Options in the Transition to This Slide group
and choose the desired option.

3. What are the ways in which you can customize the Slide Transition?

Ans. To customize the Slide Transition we can add sound effect while
the slide moves to the next slide clicking on Sound in the Timing
group. We can also change the speed of the slide transition. Click
on Duration and enter the amount of time duration.

Il. Fill in the blanks:
Ans. 1. Animation, Transition 2. None

3. Speed, sound 4. Preview

ll. Match the following:
Ans. 1) a 2)c )b
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l. Answer the following questions:

1. What is Animation? Name the different types of animations in
PowerPoint.
Ans. Animation refers to the movement of a text or object on a slide.
Following are the different types of animations in PowerPoint:
1. Entrance animation 2. Emphasis animation
3. Exit animation 4. Motion Path animation

2. Write down the steps to apply animation in PowerPoint.

Ans. 1. Select the text or object you want to animate.

2. On the Animations tab, click on the More drop-down arrow in
the Animation group.

3. A drop-down menu of animation effects will appear. Choose the
desired effect.

4. The animation will be applied to the text or object and a small
number next to it would be shown.

5. Click on Preview in the Animations tab, to view the animation
effect.

6. Click on Add Animation to apply multiple animations to the
same object or text in a single slide.

3. Write down the steps to apply sound to animation in PowerPoint.

Ans. 1. On the Animation tab, click on the Animation Pane in the
Advanced Animation group.

2. Select the object or text in the Animation Pane and click on the
drop-down arrow.

Select Effect options from the drop- down menu.
Click on the Sound drop — down menu and choose a sound.
Click on OK to add the sound.

Click on preview in the Animation tab, to view the animation
effect with sound.
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6. Text and Object Animations

| Exercises

ll. Match the following:
Ans. 1) c 2) a

contd...

1. Fill in the blanks:
Ans. 1. Animations
2. Animation pane
3. Animations

4. Preview



l. Answer the following questions:

1. What does the template usually contain? Name any three of them.

Ans. A PowerPoint template is a pattern of a slide or a group of slides
containing designs and guidelines to prepare a presentation. The
names of these templates are Layout, Theme colors, Theme
effect, Theme font, Background styles, Content.

2. How do you change the background on the template?

Ans. 1. To change the background, click on the Slide Master tab, in the
Background group, click on Background Styles, and then select
a background you would like to apply.

2. Click on the Format Background option and customize your
own background.

3. Write down the steps to save a template.
Ans. To save a template:

1. Click on File — Save As.

2. In the File name box, type a file name.

3. In the Save as type from the list, select PowerPoint Template,
and then click on Save.

Il. Fill in the blanks:
Ans. 1. Template
2. View
3. Save As
4. Standard 4:3 or Widescreen (16:9)



|. Answer the following questions:

1. List the different ways in which a slide can be viewed.

Ans. Normal, Outline View, Slide Sorter, Notes Page and Reading View
the built-in views in which a slide can be viewed :

2. Explain the Slide Sorter View.

Ans. In Slide Sorter, the slides are arranged horizontally as thumbnails.
It is helpful in rearranging the slides.

3. How do you add slides in Slide Sorter View?

Ans. To add slides in Slide Sorter View:

1. On the View tab click on Slide Sorter view in the Presentation
Views group.

2. In the grey space between two slides where you want to add a
slide Right click and select New Slide OR on the Home tab,
Click on New Slide in the Slides group and choose the desired
layout.

4. How do you rearrange slides in Slide Sorter View?
Ans. To rearrange slides in Slide Sorter View:

1. Switch to Slide Sorter view.

2. Select the slide you want to move.

3. Click and hold the selected slide.

4. Drag and place the slide where you want to move the slide.



8. Presentation Views
i m contd...

lI. Fill in the blanks:

Ans. 1. five
2. Master
3. Slide Sorter
4. Reading

5. Thumbnails pane, Notes pane and Current slide.

lll. Match the following:

Ans. 1) a 2) b 3) d 4) c



|. Answer the following questions:
1. What is HTML?

Ans. Hyper Text Markup Language (HTML) is the standard markup
language for creating web pages and web applications. It is a
documentation language to design headings, title, tables,
hyperlinks, forms of a webpage. It is universal language to design
a static webpage.

2. What are the advantages of HTML?
Ans. 1. The process of designing is more flexible.
2. It is very easy to understand, modify and interpret.

3. Multimedia, graphics and text of different types can be added
to the page.

4. 1t enables you to link two or more pages.
5. It requires only a text editor and a web browser.
3. What is Tag?

Ans. Tags are the special codes written within the angle brackets (<>).
These tags indicate the structure, format and the content of the
web page. HTML document always starts with the <HTML> tag
and end with the </HTML> tag.

4. Explain the basic structure of HTML.

Ans. Every HTML document has two sections which begin and end with
<HTML> tag.

1. HEAD section, in HEAD section title is the most important item.
TITLE begins with <TITLE> tag and ends with </TITLE> tag.

2. BODY section, this tag is used for indicating the main content
section of the HTML document.



10. An Introduction to HTML

contd...

| Exercises|

5. Explain the Head tag.

Ans. HEAD tag begins with <HEAD> tag and ends with </HEAD>tag.
In HEAD section title is the most important item. TITLE begins
with <TITLE> tag and ends with </TITLE> tag.

ll. State whether the following statements are True or False:

Ans. a. False b. True c. False
d. True e. True f. True
g. True h. True i. True

lll. Complete the following table:

For answer refer to the table on page no. 41 (The most important tags
are)



|. Answer the following questions:
a. What is CSS?

Ans. CSS stands for Cascading Style Sheets. It describes how HTML
elements are to be displayed on screen, paper or in other media. It is
used to define styles for your web pages, including the design, layout
and variations in display for different devices and screen sizes.

b. Explain New Line.

Ans. To start the text with a new line, the <BR>tag is used. The
<BR>tag inserts a single line break. The <BR> tag is an empty tag
which means that it has no end tag.

c. What is abbr?

Ans. The <abbr> tag defines an abbreviation or an acronym, like “Mr.”,
“Dec.”, "ASAP", "ATM". Marking up abbreviations can give useful
information to browsers, translation systems and search engines.

lI. Fill in the blanks:

Ans. 1.inline

2. thematic break
3. quotation



12. F:rmatting a Web Page

[. Fill in the blanks:

Ans. 1. <mark>

2. <DEL>
3. <>
4. <SUP>

ll. Match the following:
Ans. 1) C 2) A 3) B 4) D

lll. True OR False:
1. False
2. False
3. True
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[. Fill in the blanks:
Ans. 1. <OL>

2. <UL> </UL> and <Li> </Li>
3. <UL>, <OL>
4. <DL>

ll. Match the following:

Ans. 1) B 2) C 3) D 4) A



[. Fill in the blanks:
Ans. 1. BODMAS

2. if...elif...else

3. input ()

ll. Answer the following questions:
1. Explain any 3 operators with examples.

Ans. 1. Assignment operators: This operator is used to assign a value
to a variable. Example: - X = 150

2. Relational Operators: These are used to show the relationship
between the operands. There are six operands.

Examples a = 10, b = 20, a == b False, a<b True

3. Logical Operators: These operators are used to combine two
or more conditional statements. They provide the result in the
form of True or False.

Example: - a = 50, b = 30, a>b and a <40

(Note: students can write any three operators from page no. 66 and 67)

2. Explain following terms:

Ans. a. Variable: - A variable is a named memory location that stores the
data and whose value may change during program execution.

b. Data type: - In Python, a data type represents the type of data
stored in a variable. The data stored in memory can be of many
types.

c. Conditional Statement: - The conditional statements check the
condition and execute the statements accordingly.



16. Iterative Statements in Pythc

l. Fill in the blanks:
Ans. 1. Range

2. four
3. control variable
ll. Answer the following questions:
1. What is the syntax of while loop? Explain with example.
Ans. Syntax for while loop:
Initialization
While <condition>;
loop body
updation

Example: To print the first 10 natural numbers.
In the above code,

Step 1: initialise the variable i to 0.

Step 2: Check the condition whether i<=10.

Step 3: If i<= 10, print the value of i.

Step 4: Increment the value of I by 1, i.e., i =l + 1.

Step 5: This process will continue till the value of i is less than or
equal to 10. The loop will terminate once the value of i
becomes greater than 10.



16. Iterative Statements in Python

w contd....

2. Explain for loop with flowchart.

Ans. The following steps are involved in the execution of for loop
statement:

[ START }
Foriin (5,10,15,20)

|

Print i

The in operatar yes

will first check if
there is a value

o the it print i

| [r




17. Functions in Python

EXercises

l. Fill in the blanks:
Ans. 1. Function
2. def
3. Builtin
ll. Answer the following questions:
1. What is the user defined function? Explain with example.

Ans. User defined functions are those that we define ourselves in our
program and then call them wherever we want.

For example: When the function has no arguments, it does not receive
any data from the calling function and does not return any value.

2. Write two uses of function.

Ans. Uses of function in Python are:
1. Code re- usability
2. Improves Readability
3. Avoid redundancy

(Students can use any two uses from above answer)



18. Introducing Photoshop

EXxercises

|. Answer the following questions:
1. Write the steps to open an image file in Photoshop.
Ans. To open an image file in Photoshop are :
1. Click the File menu at the far left of the Photoshop menu bar.
2. Click Open.
3. Browse to an image file on your computer and select it.
4. Click the Open button.

2. Which tool allows you to make a precise selection of an image you
wish to edit?

Ans. Lasso tool allows the user to make a precise selection of an image
to edit it.

3. What does the Eye Dropper tool do?

Ans. The Eye Dropper tool takes color samples from colors on the page
and displays them in the Color Boxes.

Il. Fill in the blanks:
Ans. 1. Pixel
2. JPG, BMP
3. Cropping



